Home / Forum / Accu's / Controlling servo from Standalone arduino (Atmega328p)
2337478288
Berichten: 2
Lid geworden op: 30 Jun 2017, 11:03

Controlling servo from Standalone arduino (Atmega328p)

30 Jun 2017, 11:09

I am experimenting with a standalone Arduino (ATmega328P on a breadboard) and I've encountered a snag when it came to control a simple (hobby) servo. The standalone is based on the plans from the Arduino website (http://arduino.cc/en/pmwiki.php?n=Main/Standalone) - it worked without a hitch when it came to controlling LEDs (fade, blink etc.).

Here is the date sheet of atmega328p
I cannot upload "wiring image" (do not have enough reputation points, as this is my first post), but it can be seen here - http://postimg.org/image/eegwnpk1v/.

When I tried to control the servo it didn't even budge, made no sound, nothing... I installed a LED on the same pin to observe what was happening (I don't have a scope) - it faded on and off. So there was an output, but I have no idea what kind of a signal it was.

I swapped it for a real Arduino (put Atmega chip back onto Arduino board and tried to control servo directly from board) and it worked without a problem. I tried everything, changing pins, trying other servos I have, analyzed the circuit (as much as that is possible without a scope) etc. In all cases (standalone/real Arduino) the servo was connected to an external supply (6V).

Any ideas?

andidelf
Berichten: 1
Lid geworden op: 10 Okt 2018, 10:32

Re: Controlling servo from Standalone arduino (Atmega328p)

10 Okt 2018, 10:44

Thanks for sharing this post with us. It is very much informative and you have explained it very well. After reading your post, i can write my essay. I want to write best dissertation essay and for that i am gathering information regarding my topic online.

Terug naar “Accu's”

[message]

Close